Carloop basic - Can't see any CAN message

Hello everyone,

I’m quite new here. My carloop basic just came in yesterday and I already need your help to start playing with my car.

I could do some basic stuffs with the carloop (particle led blinking, socketcan firmware flashing). But then when I plug the carloop with socketcan firmware to my obd2 port, candump/cansniffer couldn’t see any can messages from the car. I could only see messages send by me using cansend. I even used cangen during a while to probe for PIDs.

For information, it’s a Renault Grand Scenic 3 from 2014.

One other thing: the commands “particle serial identify” or “particle serial monitor” all returned an error “serial timeout”.

What do you think about this case? Thanks in advance for your help.


So here’s what I’ve done so far: I bought a wifi ELM327 and a OBD2 splitter to sniff CAN messages using the carloop.
The ELM327 works well, while I’ve still got nothing on the carloop.

Any chance there’s a problem with my carloop?


Ok, so I flashed the VIN reader app (, but it seems that the CAN interface doesn’t work (my car was on, and the ELM327 worked fine):

I’m thinking my carloop basic unit is faulty.

May I get some help from @alanm or @jvanier please?


hey, from your screenshot it looks like you are using a Windows Operating System. Have you tried using a Linux Virtual Machine with socketcan?

Hello Alan,

Yes I tried with both virtual and non-virtual Linux.


@ngocdh, It looks like from your screen shot that you got the particle serial monitor working okay.
It also looks like that VIN reader app flashed okay, since it is trying to read the VIN.
Usually, that is all it takes to get going…

Can you verify that your Photon is plugged into the Carloop securely?
Also, can you verify that the Carloop is plugged into the OBD2 splitter securely?
You could even try plugging the Carloop directly into the car without using the splitter.
Those checks all address potential connection problems. After that, I would suspect a problem with the Carloop or the Photon.

One thing that is strange from your screenshot is that “dhp” shows as offline when you do particle list, but the particle serial monitor is working. Do you have more than one Photon, or more than one particle account? Is the Photon named “dhp” plugged into the Carloop?

Thanks alot @cyclin_al1 for the thorough analysis of my screenshot. It’s very much appreciated.
Actually the part where the photon was offline is irrelevant, that was when I restarted the photon. You can see that the VIN reader app could detect the photon when it was back online.
I have only one photon and one particle account.
I did try many times to plug the Carloop directly to the OBD2, or to the splitter, with or without the ELM327, and all that with Windows, Linux, and Linux VM. Nothing could make the carloop read anything from the CAN bus.
Seeing that operations work quite well with the photon, I’m thinking there’s a problem with the carloop, because so far, it’s the only component that hasn’t show any “signal”. The led was on when I plugged the carloop to the car without usb cable though.

And it’s a carloop basic unit that I just purchased, so yes I supposed the photon is plugged into the carloop, or am I missing something maybe?

Yes, the Carloop basic comes with the Photon already plugged in. Maybe try unplugging it then plugging it back in, just to make sure the connection is secure.

Oh, I just thought of something. The Carloop power supply expects to get its power from the car. I am not sure if the CAN transceiver chip will power up if that supply is missing. So, I forgot to ask earlier if you are plugging it into a car, or just using power from USB? (I will have to try that one myself.)

@cyclin_al1 the carloop takes power from both my car and the usb connection. And when it’s only plugged into the car, the photon’s led blinks, so I guess the photon is plugged into the carloop.