GPS suddenly stopped getting fixes

I’ve been using the GP-735T from sparkfun for like three days without any problem. It was getting fixes pretty quickly, but it suddenly stopped working. It’s not getting fixes even when I take a walk or go out with my car.

Is this a problem with the carloop or there is a chance that this is a malfunction with the GPS ?


It seems that the Carloop device is not working properly. I can’t read data from my car/emulator like I was doing before. Hence, the problem with the GPS fixes.

What are the odds that a Carloop device got ruined ?

Is there any function/way to get info if the Carloop device is good to go ?



Have you tried removing your Photon/Electron/RedbearDuo from the Carloop and check to see that the microcontroller works on its own? When on their own, you can power these from USB.
If the microcontroller does not work on its own, then check the community forums dedicated to your microcontroller.

If your microcontroller is working, then the most likely thing to look at is the voltage regulator and power protection circuitry on your Carloop. Since both GPS and the CANbus stopped working, I would assume a power issue.

If you have some electronic skills, you can test your Carloop circuitry. The circuit information is on Github:

Take a look at the board and schematic files for v2.3.

If there is a hardware problem and you find it, it should be possible to change the faulty parts by hand soldering, so long as you have a little bit of skill with SMD soldering.

Thanks @cyclin_al1 for your answer.

The microcontroller works on its own. And it even works when the carloop is plugged in a car OBDII or to my CANBus simulator. So the voltage is passing through the carloop but it’s not reading anything.
I tested simple examples from your github repository that worked before but now they don’t work.

As you said, it’s maybe a particular part but I don’t which one it is. I will try to find out what it is.



I would recommend checking that the firmware you expect is flashed to the microcontroller.
Besides that, it sounds like you need to troubleshoot at a lower level.

The next thing to check is if there are signals on the CAN_TX and CAN_RX connections between the microcontroller and the CAN transceiver chip. Do you have an oscilloscope; that would be the ideal tool? Alternately, maybe you can use your CANBus simulator and connect it to those lines on the Carloop and detect signal traffic that way.
That will indicate if the microcontroller is talking to the transceiver and vice versa.

1 Like

Thanks @cyclin_al1I will check that out and try to share my experience if I can get to any conclusion.

I send you a PM, it would be great if you can check it out.

Thanks once again.