Photon wont connect to A2 security on new iphone xs. Ideas?

I have 2 wifi Photon OBD2 dongles that send CAN data to an IP address that I can check on my phone or tablet. Previously both Photons would connect to the wifi hotspot on my verizon cell phone. I had an iphone 6. It worked well.

I finally upgraded and got a new iphone xs. I tried to connect the two Photons and they wont connect to the new wifi of the iphone xs. I took my sim card out of my phone and plugged into my verizon ready ipad (its not currently activated with its own service), went through the set up process, and the Photons connected no problem.

So it definitely has something to do with the new A2 security in the new iphone xs. Any ideas? I could sign up the ipad with its own Verizon service but thats another $20 a month! Id prefer not to spend that when I already have it on the iphone.

The answer is already here:

By the way, it makes things a bit more difficult when the pertinent details are spread out in 2 different posts…

This forum is not very active so you’ll forgive me for trying another resource.

Yes, you have responded in all 3 of my threads about this referring to your own posts in other threads and linking everything together. You have made it kind of confusing. We have already tried doing what you suggested before you suggested and those haven’t worked.

We have reached out to a representative at Particle and they too are looking into this new security format from Apple.

If anyone has experience with A2 security in the new apple products please let us know.


So which method(s) did you try to add WiFi credentials to your Photon to allow access to your new iPhone?
Did you try the mobile app, the CLI or the online method? What happened? What were the error messages if any?

I do not have the mobile app. With the help of someone else, we used a terminal window on my Macbook.
We asked Particle to show us the wifi signals. We tried connecting it to my house, WPA, and it worked. We connected it to my ipad, WPA, and it worked. But when we try to connect it to my Iphone xs, A2, it wont connect to the internet.

No error messages, the unit just continually blinks green saying its not connected.

Since this is an issue with connecting the Particle Photon to an iPhone XS mobile hotspot let’s move the conversation to the Particle forum.