Problems sending traffic through Carloop

Hi all!!
I am experiencing some troubles while sending CAN messages to an Opel Corsa 2018. I already read several posts on this forum related to this but none of them did work for me so I will try to explain this as much as possible, wondering any of you guys had similar problems/know how to fix this:

  • I am using a 2018 Opel Corsa.
  • My goal is being able to intercept traffic (done) and reproduce the same traffic (not done), in order to reproduce the action (e.g turn on lights) and then splitting the dump in two recursively till I get one packet left. This packet will be the one generating the action.
  • I followed this post ( to flash my Photon and configure it on my Linux VM.


  • I can perfectly sniff traffic but, when I try to replay it I can see (using “ifconfig can0” and looking at TX packets) that no packet is sent.
    Note1: As far as I disconnect the photon from my car and I try again, I can see all the traffic I want to send, passing through the interface. If I connect the photon to the car, and send packets again, I don’t get anything.
    Note2: I get that famous error of “write: No buffer space available”, but even before getting it there are not packets sent (but canplayer thinks it is sending them).

Things I tried:

  • Adding txqueuelen 10000 to can0 configuration
  • Use canplayer with -g but it appears to ignore that parameter (or looks like that)
  • Create a basic script to manually sleep between each packet (sent with cansend)
  • Adding UART speed to the serial port while configuring with slcand (slcand -o -t hw -s6 -S 3000000 /dev/ACMX can0). This only made the error “write: No buffer space available”, to appear faster.

I have no clue on what can be happening, is it something related with slcand configuration? Maybe I need to do some modifications on the firmware? (this is the one I used Particle Web IDE)

Hope you can throw me some useful hints… Hehe

PS: If anyone knows any other method to know which message ID is responsible for an action on the car (whatever is valid, lights, open/close doors, turn on/off radio…) it is more than welcome!! :slight_smile:

Thanks in advance!

UPDATE: I am trying to find why cannot send packets, so I tried to simplify it the most. Using the information on this thread (How to Request VIN - Software - Carloop Community) I tried to retrieve the VIN. No luck with it, but I found I am able to send exactly 7 packets, nvm if I do it manually (cansend) or not. After this, the error appears again and no packets are sent. :S